Performance

Performance

The performance of Abstract Branches is directly correlated to the number of pages and libraries used within a project combined with the size of each file. Complexity increases as the number of pages and libraries are pulled into any project. For example, a 25 MB file spread across two pages would be quicker to process in Abstract than a 5 MB sketch file with 100 pages.

If you’re experiencing slow performance while using the Abstract desktop app, you can complete the following steps to help improve performance.

Manage project files

When making performance-related changes to your project files, you can export project files to Sketch files outside of Abstract. Once you’ve made changes, you can import the files into a new project in Abstract, which helps the project start with smaller files and less data. You can then archive the original project in Abstract to maintain its history but remove it from your organization's current projects.

To help improve project performance, you can make the following changes to your project files.

Reorganize your files

We recommend keeping files below 250MB in size. If you're working with files larger than that, or especially complex files with hundreds of layers or dozens of pages, consider reorganizing your work into smaller files.

Reduce file size

  • In Sketch, use File > Reduce File Size.
  • Use compressed images to limit the file size in your project. Use .png or .jpeg formats for images in Sketch instead of DNG or RAW.
  • Use libraries to manage file sizes, maintain a single source of truth for your symbols, and help organize your work. See Libraries for more information.

If you are only making adjustments to existing projects and do not create a new project to import the updated files, you may only see small performance improvements. Existing projects contain additional data created by the project history.

Clear loose project data

The following steps can be used in an existing project. You must have Git installed locally to perform these steps.

  1. Help > Enable Development Menu
  2. Right click the project from the project tab > Development > Repack Project
  3. Help > Disable Development Menu

If you’re still having issues with performance after trying these troubleshooting steps, you can perform a reinstall of Abstract and make sure that the associated folder is also removed.